E-mail List Archives

Re: Voiceover 10 and ARIA

for

From: Moore,Michael (Accessibility) (HHSC)
Date: Sep 27, 2016 10:34AM


Which is why I find the "accessibility supported" section of WCAG 2.0 compliance to be the most difficult to assess. About the best we seem to be able to do is to say that it worked on this date with this combination of OS, Browser, AT, and code ...your mileage may vary.

Mike Moore
Accessibility Coordinator
Texas Health and Human Services Commission
Civil Rights Office
(512) 438-3431 (Office)

-----Original Message-----
From: WebAIM-Forum [mailto: <EMAIL REMOVED> ] On Behalf Of Paul J. Adam
Sent: Monday, September 26, 2016 4:39 PM
To: WebAIM Discussion List < <EMAIL REMOVED> >
Subject: Re: [WebAIM] Voiceover 10 and ARIA

No problem, just filed a bug, https://bugs.webkit.org/show_bug.cgi?id2578

Paul J. Adam
Accessibility Evangelist
www.deque.com

> On Sep 26, 2016, at 1:09 PM, JP Jamous < <EMAIL REMOVED> > wrote:
>
> Thank you Paul.
>
> -----Original Message-----
> From: WebAIM-Forum [mailto: <EMAIL REMOVED>
> <mailto: <EMAIL REMOVED> >] On Behalf Of Paul Adam
> Sent: Monday, September 26, 2016 12:40 PM
> To: WebAIM Discussion List < <EMAIL REMOVED>
> <mailto: <EMAIL REMOVED> >>
> Subject: Re: [WebAIM] Voiceover 10 and ARIA
>
> Investigated this and found that aria-label and aria-labelledby are
> broken for links in iOS 10.0.2. This demo shows the bug
> http://pauljadam.com/demos/linkpurpose.html
>
> Sent from my iPhone
>
> On Sep 26, 2016, at 9:23 AM, JP Jamous < <EMAIL REMOVED> > wrote:
>
> If it is working why fix it?
>
> I wonder about some manufacturers.
>
> -----Original Message-----
> From: WebAIM-Forum [mailto: <EMAIL REMOVED>
> < <EMAIL REMOVED>
> <mailto: <EMAIL REMOVED> >>] On Behalf Of Don Mauck
> Sent: Monday, September 26, 2016 8:41 AM
> To: WebAIM Discussion List < <EMAIL REMOVED>
> <mailto: <EMAIL REMOVED> >>
> Subject: Re: [WebAIM] Voiceover 10 and ARIA
>
> I did see a note on that last week. I thought yesterday's update might have resolved that, however, have not tested that yet today.
>
> -----Original Message-----
> From: JP Jamous [mailto: <EMAIL REMOVED> <mailto: <EMAIL REMOVED> >
> < <EMAIL REMOVED> <mailto: <EMAIL REMOVED> >>]
> Sent: Monday, September 26, 2016 2:38 AM
> To: WebAIM Discussion List < <EMAIL REMOVED>
> <mailto: <EMAIL REMOVED> >>
> Subject: [WebAIM] Voiceover 10 and ARIA
>
> Morning folks,
>
>
>
> Has anyone noticed any issues on iPhones using iOS 10 where voiceover does not recognize aria-labelledby and aria-describedby?
>
>
>
> I was told that Voiceover is not recognizing the above ARIA attributes in the iOS 10 and 10.0.2 release.
>
> > > <http://list.webaim.org/>; List archives at
> http://webaim.org/discussion/archives
> <http://webaim.org/discussion/archives>;
> > <mailto: <EMAIL REMOVED> >> ______________ > http://list.webaim.org/ <http://list.webaim.org/>; List archives at
> http://webaim.org/discussion/archives
> <http://webaim.org/discussion/archives>;
> > <mailto: <EMAIL REMOVED> >
>
> > > archives at http://webaim.org/discussion/archives
> > > > archives at http://webaim.org/discussion/archives
> >
> > > archives at http://webaim.org/discussion/archives
>