WebAIM - Web Accessibility In Mind

E-mail List Archives

Re: firefox and jaws with aria

for

From: westbchris@gmail.com
Date: Dec 22, 2018 6:27AM


You are correct Jaws doesn't react to changes with aria-live set to off. But
in some cases I am seeing the previous page in Jaws's virtual buffer even
though I know the page has actually changed. That's what I am confused
about. I understand why Jaws isn't reading the whole change, but I don't
understand why when arrowing through the document Jaws continues to see old
content. It seems that going into forms mode or whatever they call that now
and going back out of it fixes the problem.

-----Original Message-----
From: WebAIM-Forum < <EMAIL REMOVED> > On Behalf Of
Wolfgang Berndorfer
Sent: Saturday, December 22, 2018 7:01 AM
To: 'WebAIM Discussion List' < <EMAIL REMOVED> >
Subject: Re: [WebAIM] firefox and jaws with aria

If aria-live ist set to "off" (default), the screen reader must not react on
changes in the live region:
https://www.w3.org/TR/wai-aria-1.1/#aria-live
Do I understand you right that jaws reacts on changes in firefox, although
aria-live is set to "off"?
Just tested a side with a live-region with no aria-live attribute =
aria-live="off" (since this is the default value).
Jaws 18 did not announce changes in Firefox 64.


-----Urspr√ľngliche Nachricht-----
Von: WebAIM-Forum [mailto: <EMAIL REMOVED> ] Im Auftrag
von <EMAIL REMOVED>
Gesendet: Freitag, 21. Dezember 2018 16:29
An: 'WebAIM Discussion List'
Betreff: [WebAIM] firefox and jaws with aria

I am a blind we developer learning angular. I have a slight problem with my
app. I just have a small app that I am playing around with right now to get
the feel of things, and I have a few angular components that I am navigating
through. I have the div around the content that is changing set to
aria-live="off" for now. I have noticed sometimes the changes are picked up
by Jaws, and sometimes I have to do an insert escape to refresh the screen
before Jaws will see the changes in firefox. Jaws and NVDA work better in
chrome. Is this a known Jaws/firefox issue? Is there something I'm doing
wrong? I'm kind of new at the whole aria thing. I know it's hard to diagnose
without seeing code, but not sure the best way to share so perhaps some
general pointers would be helpful. Sorry for the beginner question.

http://webaim.org/discussion/archives
http://webaim.org/discussion/archives