E-mail List Archives

Re: Skip to Main Content takes a user to a "blank line" above the h1 it's supposed to

for

From: Steve Green
Date: Nov 23, 2017 12:45PM


That doesn't sound like a problem to me - they will hear the heading when they navigate downwards. The only way to be absolutely sure is to do some user testing, but personally I would focus my resources on more important issues.

-----Original Message-----
From: WebAIM-Forum [mailto: <EMAIL REMOVED> ] On Behalf Of Sarah Jevnikar
Sent: 23 November 2017 19:18
To: WebAIM Discussion List < <EMAIL REMOVED> >
Subject: Re: [WebAIM] Skip to Main Content takes a user to a "blank line" above the h1 it's supposed to

Trouble is that if reading stops, it's not clear where you've landed. If STMC's activated and all a user hears is "blank", it doesn't provide much clarity.

-----Original Message-----
From: WebAIM-Forum [mailto: <EMAIL REMOVED> ] On Behalf Of Patrick H. Lauke
Sent: November 23, 2017 12:09 PM
To: <EMAIL REMOVED>
Subject: Re: [WebAIM] Skip to Main Content takes a user to a "blank line" above the h1 it's supposed to

On 23/11/2017 16:47, Sarah Jevnikar wrote:
> It appears the target is a region rather than the heading itself or the article containing it.

that sounds like expected behavior. You activate the skip, you jumped to the start of the main content, then continue using readings keys or TAB to move forward from there.

P
--
Patrick H. Lauke

www.splintered.co.uk | https://github.com/patrickhlauke http://flickr.com/photos/redux/ | http://redux.deviantart.com
twitter: @patrick_h_lauke | skype: patrick_h_lauke