E-mail List Archives

Re: Combo box not Speaking the Label When Tabbing

for

From: Joey G.
Date: Nov 27, 2017 2:23PM


I already fixed the problem by adding an ID to the combo box which the label is supposed to be targeting. Thank you for your willingness to help.

-----Original Message-----
From: WebAIM-Forum [mailto: <EMAIL REMOVED> ] On Behalf Of Srinivasu Chakravarthula
Sent: Monday, November 27, 2017 1:16 PM
To: WebAIM Discussion List < <EMAIL REMOVED> >
Subject: Re: [WebAIM] Combo box not Speaking the Label When Tabbing

If it has associated label, it should read by screen reader. Can you please share the link / code snippet to look at? I use word press to good extent.
Playing more these days. so may be able to investigate.

Regards,

Srinivasu Chakravarthula - Twitter: http://twitter.com/CSrinivasu/
Website: http://www.srinivasu.org | http://serveominclusion.com

Let's create an inclusive web!

Lead Accessibility Consultant, Informatica


On Mon, Nov 27, 2017 at 4:58 AM, Joey G. < <EMAIL REMOVED> > wrote:

> Hello.
>
> Is this a normal behavior that when I land on the combo box when I
> press tab from a prior form field all JFW is saying is the word
> (required) and not the label I put which is (subject)? Note that I
> have less control with the HTML code since the form is made by a WordPress plugin.
>
> This is not part of the question but I notice there's the
> aria-invalid="false" in the code. I'm saying this because I once read
> a thread here discussing the announcement of the invalid message even
> the field is empty.
>
> > > archives at http://webaim.org/discussion/archives
> >